# Creating custom 404 docs. "kirupaForum, I have a problem"

**URL:** https://forum.kirupa.com/t/creating-custom-404-docs-kirupaforum-i-have-a-problem/56014
**Category:** Uncategorized
**Created:** [June 29, 2004, 9:20pm UTC](https://forum.kirupa.com/t/creating-custom-404-docs-kirupaforum-i-have-a-problem/56014 "2004-06-29T21:20:30Z")
**Posts on this page:** 2
**Page:** 1

<div class="post-metadata">

### Author: ![cadmiumgreen](https://avatars.discourse-cdn.com/v4/letter/c/ba8739/32.png) [@cadmiumgreen](https://forum.kirupa.com/u/cadmiumgreen)
#### Post date: [June 29, 2004, 9:20pm UTC](https://forum.kirupa.com/t/creating-custom-404-docs-kirupaforum-i-have-a-problem/56014/1 "2004-06-29T21:20:30Z")

</div>

Okay, i want to create custom error documents other than the usual 404. My web hosting company said it’s simple, all you have to do is the following…

1. Create an .htaccess file in the www directory.

2. In the .htaccess file, add text like the following:  
ErrorDocument 401 /myfile.htm

…and save it.

1. I completed those 2 aforementioned steps and I tried testing it by putting an unknown file after the domain name…AND I still get the same generic Microsoft 404 Error Page. :puzzle:

Can someone please tell me what I’m doing wrong? How can I correct this?

sincerely,  
cadmiumgreen

---

<div class="post-metadata">

### Author: ![system](https://canada1.discourse-cdn.com/flex011/uploads/kirupa/original/3X/6/2/621e5c11736f46532526e61be85940af4230f3e5.png) [@system](https://forum.kirupa.com/u/system)
#### Post date: [July 15, 2004, 1:54am UTC](https://forum.kirupa.com/t/creating-custom-404-docs-kirupaforum-i-have-a-problem/56014/2 "2004-07-15T01:54:54Z")

</div>

> [@UNFLUX](#):
>
> I just realized what the problem might – use URL’s the error pages, not relative links. 😉 change your code to:
> 
> ```auto
> ErrorDocument 401 http://www.domain.com/myfile.htm
> 
> ```

tech support at [phpwebhosting.com](http://phpwebhosting.com) told me that in order to fix the problem that I’m having…I must make sure my documents needed to be over 512kb.

I’m not sure what they mean ( i was hoping you can explain that to me :nurse: ) but the remedy you provided to me is what solved my problem. :sure:

thank you.
