# Large numbers on Linux CentOS

**URL:** https://forum.kirupa.com/t/large-numbers-on-linux-centos/219469
**Category:** random
**Created:** [March 16, 2007, 6:15pm UTC](https://forum.kirupa.com/t/large-numbers-on-linux-centos/219469 "2007-03-16T18:15:15Z")
**Posts on this page:** 1
**Page:** 1

<div class="post-metadata">

### Author: ![kdd](https://avatars.discourse-cdn.com/v4/letter/k/ecb155/32.png) [@kdd](https://forum.kirupa.com/u/kdd)
#### Post date: [March 16, 2007, 6:15pm UTC](https://forum.kirupa.com/t/large-numbers-on-linux-centos/219469/1 "2007-03-16T18:15:15Z")

</div>

I wrote a script in php that would count number, but when it reached about 64,000-65,000, server gave me internal server error. I think the reason was due to number going over the max integer limit. What kind of variable declaration should I do to overcome that limit in php?

Thanks.
