Can't get a transition to work

I’m very new to Flash so please forgive any obvious questions! I have a problem with a ‘simple’ transition that is driving me mad…

I have a scene with a button named ‘technical’ and the code for the button calls a frame named ‘technical’. In this frame, I have a movie clip which contains some text. When I click the button, it opens the movie and displays the text nicely. So far so good!

I decided that I wanted the text (i.e. the movie) the fade in with a wipe. This is what I tried:

  1. Select the movie in the ‘technical’ frame.
  2. Right-click and choose ‘transition’
  3. Choose wipe direction and number of frames

When I test the scene, I select the ‘technical’ button and it plays the movie and fades in the text just as I want - except it repeats and ignores any ‘stop’ commands that I enter. I thought that I knew about using ‘stop’ and have used it successfully elsewhere - it certainly works when I remove the transition from the movie clip. So, then I wondered if perhaps I should display the text as a graphic rather than a movie clip. This is what I did:

I converted the text to a graphic symbol and inserted this in the ‘technical’ frame (instead of the movie). I tested the button before adding any effects and it all works (and stops) as expected. However, once I appy the transition and test the scene, pressing the ‘technical’ button displays nothing. I can see that the fading graphic works by checking each frame in the timeline - it fades in gradually just as I want - it just doesn’t display when I run the scene.

So now I’m stumped. Using a movie, I can’t seem to stop it. Using a graphic, it doesn’t display. Can anyone save my sanity?!

Thank you :slight_smile: