Dot syntax hell

I have attached a simple test fla.

I am trying to centralize my code in all my movies using dot notation instead of spreading my code all over the place. It never works, I must be doing something wrong.

The test .fla has a movieclip with a timeline animation. I used the linkage identifier to name it ‘reload’ AND named the instance ‘reload’.

_root.reload.onRollOver = function() {

…yields nothing. The pointer doesnt even change to a hand.

What am I doing wrong?!?!?!?

1st) You dont have any actions on the buttons in the last frame. Put those actions that are on the 1st frame on the last frame.
2nd)Why are you using the linkage property?

Hey Claudio, saw your tut got accepted. Way to go.

My last frame contains a movie clip not a button. I want to call on the movie clip to do something. I have read that it is good coding technique to centralize all the code in the 1st frame.

I used the linkage identifier because I tried everything else and nothing works.

Is something like this? :-
And yeah my horrible tutorial got accepted :stuck_out_tongue:

Yeah that works, but why cant I call the same action if the target is on another frame in the movie?

For instance, what if I have several instances of the same movie clip in my main timeline. I want to be able to call them all from one location instead of adding the same script to every frame.

Does that make sense?