Flash Player 8 settings with trouble?

I have movie I just saved as Flash 8, but now my textfields are not showing up.

All of my textfields have a FFF embedded and they all worked just fine but ever since I converted the file to Flash 8 they are not showing up.

This problem seems to be happening only when viewed from within the browser, if you open the swf file, all of the textfields work fine

Also, if I publish with the Flash Player 7 settings the problem is solved both in the swf file and from within the browser.

I have another problem switching from and to Flash Player 8 when using the aligner class from Elvis Mehmedovic http://emehmedovic.com/
The first time I publish the movie I get 3 errors, but if I publish again… the errors are gone

this is a transcript from the output panel

[font=Courier New]Error C:\Documents and Settings-MaIQ-\Local Settings\Application Data\Macromedia\Flash 8\en\Configuration\Classes\FP8\System\capabilities.as: Line 7: The name of this class, ‘System.capabilities’, conflicts with the name of another class that was loaded, ‘System’.

Error Symbol=mcStageBack, layer=Layer 1, frame=1:Line 1: There is no property with the name ‘capabilities’.
this._width = System.capabilities.screenResolutionX

Error Symbol=mcStageBack, layer=Layer 1, frame=1:Line 2: There is no property with the name ‘capabilities’.
this._height = System.capabilities.screenResolutionY

Total ActionScript Errors: 3 Reported Errors: 3

Any ideas ??