Having trouble with custom scroll buttons

I made my own scroll buttons ( just up and down arrows ). Everything worked all nice until i put everything I made into a movieclip. Now the scroll buttons won’t work. I’ve attached the .fla if anyone is interested in helping me.


[SIZE=7]Welcome to the forum zao!![/SIZE]
I looked at your file and noticed you had some targetting problems so I made the changes. I gave your text box an instance name of “box” so I could target it and then I applied this action to your button:


So now your button is able to target the textbox while it is inside the movieclip you made. Here is your file. =)

Well that was simple enough, thank’s a lot man. I’m not new to these forums :slight_smile: I just haven’t been here in awhile :smiley:

hahah oh oops, I thought you were new since I saw only 1 post, but glad you decided to come back. =)

Well now that I know how to target stuff that’s good. I can’t seem to get it to work in the flash movie that i’m working on though. The scroller is nested in like 3 MC’s…ummmm i targeted it all correctly, but it still doesn’t seem to work.

Upload your files so I can take a look at it, be easier for me to see what you did and maybe I can fix it.

I sure can.



Ok I looked at your file and the problem was that your AS was targeting a misspelled instance name of your textbox. You had “hisTest” when it should of been “hisText”. It’s a pretty common mistake, so just recheck your work next time. Go ahead and make the correction and it should work fine.

Doh! Man do I feel stupid. I was gettin so stressed out too.

haha, I was going kinda crazy too cause I couldn’t see why it wouldn’t work because you set it up just like the other one. =)