Loading dynamic/static txt from a MC: Strange behaviour

Funny behaviour…I’m trying to load an external MC containing dynamic text (MC-Clip.swf) to a MC empty holder (MCimport) within my main/parent movie.

This piece of AS is attached to a button (to call the dyn. txt clip):

on (release) {
_root.loadMovie (“MC-Clip.swf”, “MCimport”);

With this, the dynamic text gets loaded indeed… but Fullscreen into the parent movie, and not into MCimport (where it should be).

Now… I don’t understand why, but the thing is that if MC-Clip.swf contains just static text (and change accordingly the text properties to static text in the holder MC), it gets loaded in the right place (MCimport) within the main/parent movie. (!!!)

And this is the piece of AS attached to the button (to call the MC containing the static txt):

on (release) {
loadMovie (“MC-Clip.swf”, “MCimport”);

In order to get loaded the dynamic text into the target MC inside the parent movie, I’ve tried many different combinations (some of them even absurd I think)…the result? same behaviour or even worse. Some of them are:

// loadMovie(“MC-Clip.swf”,_root);
// _level0.loadMovie(“MC-Clip.swf”, MCimport);
// this.loadMovie (“MC-Clip.swf”, “MCimport”);
// loadMovie (“MC-Clip.swf”, this);
// _root.MCimport.loadMovie(“MC-Clip.swf”,this);

// clip=“Mcimport”;
// loadMovie(“MC-Clip.swf”, this.clip);
or // loadMovie(“MC-Clip.swf”,_root.clip);
or // loadMovie(“MC-Clip.swf”,_parent.clip);

Is it strange indeed or am I doing something wrong? Can somebody help me please?? I’m going mad with this silly thing and I’ve run out of ideas!!

Thank you!

to link a seperate swf to a empty mc it should be:

[AS]on (release) {
loadMovie(“MC-Clip.swf”, MCimport);

Someone can correct me if I am wrong, but thats what works for me.

Thanks TitrationX. That’s correct…but in your example I don’t seem to see any dynamic text being loaded.

My problem is not when loading an external MC to the main/parent movie, my problems start after that.
If you want to have a look at it all, here you are the zipped fla (12Kb): Fla (Flash 5!)

Unzip all files to a folder and double click on Loading Dyn TXT.swf to start.
Thanks again! Let’s see if we can work it out! :wink:


I’ve already tried it with FLASH MX, but the problem persists…

Any idea?
Thank you!



…I’ve been able to see that it was a problem of Windows FLASH PLAYER!!!..
I normally work with Flash 5 but I also had a demo version of FlashMX coexisting in the same computer.
For any strange reason default player in my Windows XP was Flash Player 5 r30. After reinstalling the Flash MX demo, the player is now Version 6 r23…and now it works…
…and the most amazing thing (GOD give me patience…but NOW! ) is that if it wasn’t for that thing on version players, I would have done it well since the beginning -as you can see in my first post above- I firstly wrote:

on (release) {
loadMovie(“MC-Clip.swf”, “MCimport”);

and seeing it didn’t work for dynamic text, I started all that mess about adding _root’s and _this and _parent’s and other desperate nonsenses of mine…(as seen in my AS-fla with many // of “non-working” and “already tried” code)

OK, nevertheless…now I’m a happy guy!
Just watch out everybody with such silly things which can bring you many headaches for details which are in a first instance, out of reach…

Happy Flashing!