loadMovie - textArea

i made a text area and in it i have data loaded from an sql database. the data shows up fine. this text area is stored in guestbook.swf

in my main swf, i have a button which loads guestbook.swf into a containerMC.
however when i press the up/down/scroll bar to go through the text in the text area (which is now loaded into my main swf), it highlights all the text in the text area, like you’re highlighting all the text with your mousecursor. i have selectable text off in the text area.

this doesn’t happen when i am scrolling through text in guestbook.swf… anyone have a solution?


you may want to double check your linkage. turns out with my problem i unchecked all the linkage and my text scrolle without a problem after that.
i always wondered why that worked out that way, but hey it worked.

hmm, i was using loadMovie… but you gave me the idea of trying attachMovie and problems have been solved! wonder why the textarea acts funky when using loadMovie…


and why is it that when i add a textarea component, it added about 140kb to my file size, which was originally 7kb???


MX 2004 uses a new component architecture,
with a lot of classes being included right from the 1st usage on,
which adds about 30k to the 1st frame even if you uncheck “export in 1st frame” on all of them.

Perhaps you should try using a dynamic text field to load in the text?

yep, did that, but had to also code a scroller which didn’t take along though, and saved 100kb+ on the file size heh.