Multiple scrolling text movies?

a while ago i asked for a script that allows scrolling for static text, to which i believe electrogeek kindly pointed me towards a <A HREF=“http://sonmi.150m.com/temp/static.fla”>fla</A> he made. however, i’d like to have more than one scrolling text option on my site, but i don’t know how to work around the movie so that i can have different text for each one. i duplicated everything in the movie, thinking that’d work, and while i did get the text to change, the scrollbar no longer worked ;(. could anyone possibly tell me what exactly i am supposed to change in the fla to make multiple scrolling text menus? thanks! :cool:

Sonmi, could you post your file so maybe I or someone here could take a look? It would help to see what you’ve done so far and maybe solve the problem. =)

i posted a link to your fla, though i guess it really couldn’t be seen-- here’s <A HREF=“http://sonmi.150m.com/temp/static.fla”>that</A>.

eh, i can’t really post my fla, because for some reason it’s 17mb :\ i can, however, post my swf, so you can see my problem with the scrolling. there is a lot of incompleteness to the page, such as wrong transitions and nonfunctional links, but those should be ignored, as i’m not finished with those yet :stuck_out_tongue:

http://sonmi.150m.com/temp/06.html

the news section was the one i used the scrolling static text for first, and it works just fine. i wanted to duplicate it again for the events section (there’s just nonsense on there now so i could test it), but i couldn’t get the scrolling to work. any help would be greatly appreciated!

Hmm…I can see the problem, but without looking the actionscripting inside it, there’s no way for me to make any changes. :frowning:

If you can then place your fla into a zip file then email it to me and I’ll take a look at it. Chances are you probably left out some coding or something and it shouldn’t take too long to fix. I’ll fix it and send it back to you. I’ll PM you my email address since I don’t want any spambots getting a hold of my email address by posting it here.

EDIT: nevermind, you’re not taking PM’s so I’ll post my email but with out the @ sign.

electrongeekz at hotmail.com

thanks a lot for the help! but on my dial up, it would take forever to upload a 17mb file. could you possibly just tell me what on your script for the scrolling static text you need to change in order to successfully make a copy of it? like what codes you have to alter, and whatnot? if not, then i could try and upload the fla to a server. thanks again for the help :slight_smile:

Sonmi, I would tell you if there was just one single chunk of code, but it doesn’t work that way. It’s a bunch of little tid bits of codes apply to varies parts to make it work. If you take a look at my original file and go into each piece and check the actions panel, you’ll see that there are codes everywhere. :frowning:

i checked it all out… and i tried changing them to make it work… but it did not :\ the thing is, is that i need more than two scrollbars as well, so if you fix the one scrollbar for me, i’ll still need another, and i don’t want to have to rely on you fixing all of it for me. i’m going to list all the codes here that i found…

<b>upactions movie, frame 3:</b>

_parent.scroll.prevFrame();
gotoAndPlay(“up”);

<b>circle with arrow (up):</b>

on (press) {
upaction.gotoAndPlay(“up”);
}
on (release, rollOut) {
upaction.gotoAndStop(“stop”);
}

<b>circle with arrow button (down):</b>

on (press) {
scroll.play();
}
on (release, rollOut) {
scroll.stop();
}

<b>scroll movie, frame 18:</b>

gotoAndPlay(“end”);


i think that’s it, disregarding all the stop() actions. now, if i were to duplicate the movie, what in that would i have to alter? i’m assuming that the “scroll.play()” and “scroll.stop()” actions refer to the movie titled “scroll,” so i know i’ll probably change them.

i guess i just would rather understand how this script works than having it fixed. i apologize for being such a bother, but i really do appreciate this help :rambo:

i think i found out what my main problem was… i just didn’t name the movie in the “text” layer (the one that was named “scroll” in your original script) the proper name. though, the up arrow doesn’t work still… hmm…

Yeah when you’re duplicating the same thing over again, you’ll have to give all the new duplicated parts new instance names.

On the original file I believe there are objects with instance names of “upaction” and “scroll”, there could be more, I’m not sure because I don’t have the file with me right now.

So when you duplicated the files to make your 2nd scroller, there are now 2 of those so you’ll need to change them to something like “upaction2” and “scroll2”, but you’ll also need to go into the actionscripts and plug in the number 2 to the corresponding instance names so that it will work. I hope I’m making sense here. :frowning:

Let me know how it goes.

thanks for the timely responses :smiley:

i changed everything, and everything seems to be working alright now… except for the up arrow :-\

i changed the upaction object to upactionsevents

so i thought that the action for the up arrow would now be:

on (press) {
upactionsevents.gotoAndPlay(“up”);
}
on (release, rollOut) {
upactionsevents.gotoAndStop(“stop”);
}

but it still doesn’t work. is there anything else i need to change to make the up arrow work? :cyclops:

i got it! yeah… those pesky instance names. anyway, thanks for all of your help, eg :D!

hehe I’m gald you got it, glad to have helped. =)

well… i just made a third scroll bar thing… and i changed everything like how i did the first one, but now nothing works again :ninja: i’ve checked and rechecked it, but can’t find out why it isn’t working. arg :\

i duplicated the text movie, the upaction, the scroll, and the text within the scroll and given then different names, and i changed the instances for upaction and scroll and updated the codes accordingly. but when i click on the arrows… nothing! ;(

i’m assuming hotmail doesn’t take e-mail attachments that are 17mb, right? i’m really stumped now, and i guess i’m best off just sending you the fla. i guess i can try uploading it to some server…

Ok, just upload it to your server and PM me the link or email it to me, which ever you prefer and I’ll see what I can do.

i must be making some terribly mad mistakes :-\ i renamed each file a more simple name, “upactions3” and “scroll3” and put them all in, and now it works. heh. sorry for all the trouble. i guess i just had a spelling error…somewhere… that i somehow couldn’t see at all :sigh:

anyway, i still appreciate the help. (-:

LoL wow that was easy, didn’t even break a sweat, man I’m getting good…hehe j/k :stuck_out_tongue: