Ok...stumped! another preloader question

[FONT=Century Gothic]if there wasn’t enough already! :ogre: [/FONT]
[FONT=Century Gothic][/FONT]
[FONT=Century Gothic]but hopefully someone can help. been through post after post and still not got there. so if someone could help out that would be great.[/FONT]
[FONT=Century Gothic][/FONT]
[FONT=Century Gothic]basically i would like to dynalically display and preload an image onto my main movie clip. this image would be the first item in my xml file. on my main timeline i would like to have a few buttons that a user could click to change the default image on the page.[/FONT]
[FONT=Century Gothic][/FONT]
[FONT=Century Gothic]when they select a new image, i would like to have the preloader appear above the default image and then tween between the old and new image (one fading out and one in kinda thing).[/FONT]
[FONT=Century Gothic][/FONT]
[FONT=Century Gothic]i sourced some code but i’ve been having problems preloading the first image. the image loads but the preloader doesn’t do anything. it seems like the preloader doesn’t seem to recognise that i’m trying to load an image. it thinks it’s fully loaded and carries on before the load can begin!! hmmm grrrrrrr! [/FONT]

[FONT=Century Gothic]i would also like attach a different preloader for the first image displayed than the ones being loaded via the buttons. [/FONT]

[FONT=Century Gothic]i’ve attached the example. hopefully it works. it’s in flash 8 format.[/FONT]

[FONT=Century Gothic]any help would be great. cheers. [/FONT]
[FONT=Century Gothic][/FONT]
[FONT=Century Gothic][/FONT]