Online Games - Firewall?

Whenever I hook myself up to an online game, In particular Warcraft 3 on, I can always join games, but I can never host them. I’ve been told it’s because I have a firewall. Is it possible that I can just disable it for that game or only allow certain games access to it? I really don’t want to compromise my computer safety by disabling the whole thing. Especially since I’m hooked up to two other computers by network. If anyone knows anything about how to resolve this type of problem, it would be a big help.


Fargate :slight_smile:

Hey Fargate!
I have that same problem also. I too would be interested in seeing any solutions for this? I have tried everything from disabling the firewall, using port forwarding for opening port 6112, etc.

Kirupa :ub:

Okay, if you have hardware firewall, try skipping that and see if it works. Also, if you’re using Windows XP, keep in mind that it has an internal firewall also.

I forgot to mention, I access the internet by router, meaning I have access from one of the other computers in my house, which I’m connected to by network. Could that affect anything? I am using windows xp, but I don’t think the internal firewall is enabled right now…you can view that by right clicking on the LAN properties or whatever right? The box that appears under the advanced tab isn’t ticked as far as I know. I have no clue if I have hardware firewall? Does that usually come with your computer? How can I check and, how do I skip it? I take you mean disable by skip right?

Thanks for the advice so far,

Fargate :slight_smile:

i was gonna say make sure you open the correct ports, and make sure the people connecting are using the same ports as the ones you are opening?

you can also setup port filtering in XP -

i know on some games/software you can use different ports to connect…

Ok well how do I make sure to open the correct ports and how do I set up port filtering???

Fargate :slight_smile:

If you have a router that would affect things - I access the internet through another PC and I have problems with some games sometimes.

You’ll need to forward port 6112 to your computer (look in the Advanced tab of your LAN to find out your IP address).

Also, if you have a router, there is really no need to have another firewall attached to your computer. The router acts like a firewall in itself - lets things go out, but not come in. You need to set up port forwarding and things like that in order to allow incoming connections. That’s what’s meant by the phrase “hardware firewall”.

edit: If you’re using Windows XP’s built in router thang, then you need to double click on your cable or DSL connection and go to Properties -> Advanced -> Settings -> Add. Type in “Warcraft 3 hosting TCP” for the service name and your IP adress for the “Computer hosting this service”. Then enter 6112 for both port settings and select TCP as the type. Then repeat this process, but entering UDP instead of TCP, and make sure the boxes are checked in the Advanced Settings box. You might also need to disable and reenable your DSL or cable connection afterwards as well, I dunno.

Well the only problem is when it comes to this kinda stuff I’m really quite computer stupid :(…Ok so I followed exactly what you told me to do in the EDIT bit of your post…I don’t think I had the thing enabled before but I guess it is now…I’ll go test it …I really hope this works >_<!

EDIT: It didn’t work :(! I guess adding the firewall to my LAN connection really couldn’t have helped matters…I did exactly what you said…no luck :-/…I even disabled, re-enabled plus restarted my computer. Could the fact that maybe the computer I’m accessing the internet from has a firewall? But you said all I had to do was “foward” port 6112…and I’m pretty sure that’s what I’ve done. Anyways I’m pretty sure it’s right…I added two…one UDP and one TCP…one’s called “Warcraft 3 hosting TCP” and the other is of course called “Warcraft 3 hosting UDP”. If I wasn’t using the built in XP firewall thing to begin with should I have fowarded it in some other way…is there another way or something else I should be doing? I dunno…

Thanks a lot for the help so far :thumb:

Fargate :slight_smile:

Try turning off all the firewalls and see if it works then :wink: If that doesn’t work, I’m not sure why it wouldn’t :frowning:

When you say turn off ALL the firewalls…that includes the firewalled LAN connection…but once I do…I no longer have the port fowarding thingy…because those options are only enabled when the LAN is firewalled…what other firewalls might I have? Under my LAN properties it says in the general tab that I’m using “CNet PRO200WL PCI Fast Ethernet Adapter” to connect. There’s a configure option under it. Is that some sort of firewall thingy. I just honestly dunno what to look for and what to disable. Would disabling firewalls include the one say on the computer I’m accessing the internet from? Am I supposed to set up some sort of port fowarding options with that connecter CNET thing?Ah this is so annoying >_<…

Thanks for all the help so far, your being very patient :p.

Fargate :slight_smile: