Photo Gallery Tutorial


Im having problems with the Create a Photo Gallery tutorial and Flash MX, when i run the movie and want it to load images from another directory on the website you have to click the forward and back buttons twice.

When i test the movie in flash the first image loads fine, then when i click the forward or back button in the output box it just keeps saying NaN, can anyone tell me how to solve this problem.

Thank You in advance.


I’ve got the same sort of problem. :*(
Besides that, I’ve also got the problem that the photos are being placed right down, instead of in the middle. This gives a strange slideshow. Can anyone tell me how I can place the photo’s in the middle of the movie?
Tnx in advance.


Part of your problem is because of the registration point in your movie clip. This is why the images are not loading in the middle. Please look at the registration point tutorial and this will show you how to fix the problem.


Well, I don’t know what the problem is with the images not loading, but I do believe that NaN stands for “Not A Number”. So maybe that can help you out in checking your code.

I’m trying to work out the MX version of the photo gallery. I can paste the code from the tutorial into my .fla and the animal images show up, though down and to the right of where I placed the MC. (tried resetting the registration pt and it didn’t seem to work). but if I put in my own files in they dissappear entirely. Just a blank space. If I use a combination the animal ones show up and mine don’t. Ideas?

I’m having the same the issue with having to push the Left Arrow (Previous Button) and Righ Arrow (Next Button) twice to rotate between the pictures. It works without any errors you just have to double click or hit arrow keys twice twice for it to work. Even more strange is the first time I had it reading from ’ pics/ ’ on my hard drive and it works fine with single clicks. However when I changed the path from ’ pics/ ’ to ’ ’ with the name of the pictures remaining the same it now takes two clicks! Any thoughts on why this would happen?