Please rewrite this statement -

i have this on a movie clip:

onClipEvent (enterFrame) {
if (_root.circle==1) {
_root.firstmc.secondmc.MC1.gotoAndStop(2);
} else if (_root.circle == 2) {
_root.firstmc.secondmc.MC2.gotoAndStop(2);
} else if (_root.circle == 3) {
_root.firstmc.secondmc.MC3.gotoAndStop(2);
} else if (_root.circle == 4) {
_root.firstmc.secondmc.MC3.gotoAndStop(2);
…and so on…
}

is there any better way of rewriting it… im sure there is… please help.

onClipEvent (enterFrame) {
if (_root.circle) {
_root.firstmc.secondmc["MC"+_root.circle].gotoAndStop(2);
}
}

thank u so very much nathan…