Proper syntax when dispatching a custom event

Just a curious question - i have a class where I’m setting a simple custom event name as a static const such as:


public static const ON_OVER:String = "HotSpot_ON_OVER";

When an instance is created in parent container object, I’m simply using:


theInstance.addEventListener(HotSpot.ON_OVER, hsOverHandler);	

Within the HotSpot class, when I dispatch that event - both of the following work, but is one preferred or more proper than the other?


dispatchEvent(new Event(HotSpot.ON_OVER));
//or
dispatchEvent(new Event(ON_OVER));