setFocus problem?


I have a inputbox in my movie but when the movie is played there is no cursor showing.

I’ve looked around and found that I need to add the:


piece of code in the first line of my movie…

This still doesn’t do anything?

What am I doing wrong?



Check list:

Is your text type set to “input text”, and is it named with an instance name?

Ensure your text is NOT white on a white background because if thats the case you’ll not see you text cursor. That got me a while back!

Is your text box in another movieclip and not on the root stage? If so you may have to change your path?

OTher than that I’m not so sure.


The text is set up as black. The input box has a instance name of inputboxand the input box is on the same level as the code.

Im a little confused.

There are three input boxes in this same movie each with a different instance name … would this cause a problem?


Thats unusual.

I’ve just done a little experiement using various text boxes and put the actionscript as:


and it worked great.

Just to clear any questions…

I’m not getting the flashing cursor until I’ve clicked on the input box?

And the code I’m using is :


(this is placed on an empty frame above the box).


Could you post me your fla of the test so I can see what I may be doing wrong?


Spence :smiley: