Shared Font - tradeMark symbol missing

this problem is starting to ****ing annoy me now.

i use a “shared library”-font.swf which includes the fonts that im using for this site. But its not problemfree…it wont show the trademark symbol. if i instead skip the shared font, delete it from my library, and embed the font in the textfields characterthing the tradeMark will show. This works but will add about 20 kb to every swf that i use the font in…instead of just being preloaded once as a shared library.swf and then cached.

Has anyone else had this trademark-****ing-error?


Your fonts in “fonts.swf” are most likely embedded, but unless you explicity told Flash to include the trademark sign or any/all special characters, it won’t add it’s outline to the library. What you need to do is tell Flash to embed the trademakr sign alogn with all other characters you’d like in the final SWF.

(it will only add a few bytes to compensate for the size of the trademark outline)

all of the above is done. Ive embedded all that i need (including TM yes…)

Ive tried this now with a few common fonts like verdana and arial…still no f**king TM-symbol. I quit. anybody want my job?

Are you dynamically loading the text? And if so, are you using Unicode characters, ASCII, or HTML-safe ones?

(If you’re not dynamically loading the text and you still can’t get the ™ to show, I have no idea what else to suggest)

through unicode - xml.

And you might want to make sure you have the proper unicode characters.