Text not working with alpha changes

I have a movieclip with some text, it starts at 0% alpha and then I want to make a simple AS that will bing up the alpha to 100%, but the first problem that I have is that when I just test it, I have the whole movieclip set to 0% alpha, yet the text is shown at 100% alpha. The text parts are supposed to be buttons so I later changed them to button and set thier induvidual alpha to 0% but they still show when I test my fla.

Ive tried set them to random alphas like 35% but you can still see them clearly with 100% alpha, its very strange and I dont understand what the problem is. I also tried to then disable the buttons with actionscript but they are still at 100% alpha.

Ive tested to break it apart, doesnt help
Ive tested to make it into a grahpic, doesnt help
Ive tested to break it apart and then group it, doesnt help

I dont undetsand, and its very easy to repeat.

I just make a sqaure, put some text in it and convert it all to a movieclip then turn the alpha down to 0, and when I test it I can still see the text, someone know what Im doing wrong?