Trace() doesnt work inside addEventListener function in Eclipse

I got this weird problem, when i run this code:

package {
    import flash.display.MovieClip;
    import flash.display.Sprite;
    public class EDHV_ImageSlider extends MovieClip
        public function EDHV_ImageSlider()
            addEventListener(Event.ENTER_FRAME, addObject);
        public function addObject(e:Event):Boolean {
              var test:Sprite = new Sprite;
            test.x = Math.random()*100;
            test.y = Math.random()*100;
            return true;

In Flash Cs3 it acts exactly as i want, the ENTER_FRAME runs and the addObject places numerous sprites on the stage. In the window output i’ll see the trace. But when i run this code in Eclipse which is set up to use the Flash Player as output i get the first trace from EDHV_ImageSlider but the traces inside addObject won’t show up, the sprites however are generated perfect.

The difference between the eclipse setup and the cs3 setup is the fact that the cs3 setup has a *.fla which calls the *.as package.

Does anyone have a clue where to look? could it be something in Eclipse?