Button Question #2

Ok, I got the button to work with the animated gif by using the movie clip. I added a sound clip to it, but I want the sound clip to play the whole time the button the mouse pointer is over the button and then, of course, not play when the mouse pointer is not over.
I have a 0.5 second sound clip that I used and inserted it into the “Over” state.
I played with the sound settings, but there doesn’t seem to be a setting to just loop the sound while the pointer is over the button. If I use ‘0’ for the loop, it only plays once after I mouse over the button.
I’m guessing I have to use an action here, but I don’t really know.

Again, thanks for any advice.

In order to get your sound clip playing continuously, you will have to put the sound clip in a new layer in the movie clip of your animated button…once you have done this give your movieclip an instance name. You can do this by clicking on Modify>Instance and in the panel that appears type a name for your movieclip in the Name option. Then right click on your button and click on actions. on (rollOver) {
tellTarget ("/name of the movieclip") {
gotoAndPlay (“frame number where the sound clip is located”);
on (rollOut) {
tellTarget ("/name of the movieclip") {
gotoAndStop (frame number where there is no sound clip);
Hope this helped…let me know

Thanks Vazash, I’ll try it and let you know how it turns out.

I Appreciate the help.

i realised a little late and am sorry but i forgot one important thing to tell u, in the layer which u have placed the soundclip, you have to have two key frames a beginning keyframe on which the sound will start and one at the end of the sound, the keyframe on which the sound ends you have to add another small action which goes like this
ifFrameLoaded (“last keyframe number of the sound clip”) {
gotoAndPlay (“start keyframe of the sound clip”);
This step will make the sound clip play continuously

You can also use labels for your keyframes so that if you need to move the keyframes around you can do so without worry as against if u move the keyframes around then you have to change the frame numbers…substitute the keyframe numbers for the labels…If you’re using labels then in the ifFrameLoaded options change the “type” from “framenumber” to “framelabel”…this is important.

Thanks again, I was about to post that I was not getting it right, Let me try again and see what happens.