Buttons hidden behind the top layer are clickable

Hey guys.

I have a movie with a few buttons. Every now and again I have to load one more movie onto another level. It covers those buttons. But even though you can’t see them, the area where those buttons are sitting still remains clickable.

Is there a way - without having to unload the bottom movie - to temorarily disable buttons inside it, until the top movie is done playing and gets unloaded?

(I guess one way to go it is to place a large invisible button inside the top movie that would do nothing but cover the entire area underneath it. This way it’ll “cancel” all the other buttons on the level below. The drawback of this, however, is that cursor would naturally become a clicking hand over the entire area…
Would be nice to find a solution that actually does not suck…)

Do what I did. I had the same exact problem, jot for tittle as your describing on my page. To see what I am speaking of, click in the Sun in my animation below and then go to File. All those buttons underneath ‘file’ are disabled because i put buttons over them. Just make real buttons. Newsites, or whatever. Be imaginative! Check out my site and you will see I overcame that problem.


If you put the buttons inside movie clips… then gave those movie clips “instance” names. Then you could use the following to activate and deactivate them


“_root.” can be replaced by _level# if levels are being used.

h mmmmmmmmmmmmmmmm