Download .pdf with FileReference causing errors

I’m trying to set up a button that will download a .pdf file when clicked. I’m using the method, and it returns an error in my browser.

After I select the location I want to download to it says that:
This plug-in performed an illegal operation. You are strongly advised to restart fireFox.

Does anyone know why this would be or what I can do to fix it?


So, after a restart of my computer, I don’t get the error message, but it doesn’t ever seem to start the download?

Does anyone know what might be causing it to look like it’s going to downlaod but never actually download? I imported the FileReference class, so that’s not it…

It just brings up the dialog box asking where to save it, but then when I click ok, the dialog box goes away and nothing else ever happens…

I don’t think kirupians can smell code, we have to be able to see it. Or did you just use the same basic code that’s in the help?

Okay. Valid point… Well let’s keep things simple. I used this code

var myFileRef:FileReference= new FileReference

The file definitely existed… I think I’ll make a sample.fla to post and see if that can help…

Very odd. I tried it myself and it doesn’t work either for me :cyclops:

I’ve worked with the filereference class before to upload files, but never to dowload files.

I found an article on that talks about the same problem, but it mentions the Flash Player 9.

I’d like to know what’s the problem too now.