Eslint Gurus?

I’m having an issue with my eslint setup. Specifically it seems to be fixing things that it is not configured to fix, it’s like doing a full replace of all semi-colons and single quotes. I have co-workers who run the same eslint all the time so I know that when I run it, it should not be making style changes to every js file in the project…

Eslint supports hierarchies so theoretically a prettier file in my system might have been causing this to happen but I’ve added "root": true to the file and I continue to have the issue.
I’ve tried a few different thing above and beyond this:
yarn cache clean
yarn lint --debug ← I would have expected this to show some config paths that would be leading to this behaviour but there were none.

Any thoughts or suggestions from the wizened JS devs of Kirupa?

I just use Quokka / Wallaby JS and “use strict”.

That’s the most Australian setup I’ve ever seen.


Who needs Jest when you can evaluate every line as you go?.. Wallaby works with Webpack and wrangler too…

Unfortunately, JS is really not my forte, especially JS configs. If this were a greenfield project I’d look into it but I don’t have that kind of flexibility at the moment… Beyond that getting this lint config to work has become sort of a personal quest.

IDK Webpack :grinning_face_with_smiling_eyes:… Cloudflare wrangler works with Webpack and it comes pre configured. I use Cloudflare worker pages specifically so I don’t have to configure Cloudflare pages (SSG, Github). Cloudflare workers are like a server worker… if you know service workers you know Cloudflare workers… KV store is like Redis… There is a similar thing Deno Deploy… except it hasn’t got a key value store… maybe soon Google or Amazon will do the same. I will say that Cloudflare workers run cloud functions sooo much faster… and cheaper…