Movie clip symbols

I often come across this problem…but i normally find some way around…(which i forget soon enough)

however i would like to know why this happens and a definate way as to deal with it :stuck_out_tongue:

when i place a movie clip symbol into my movie, it doesn’t play immediately flash comes across the frame it is in.
y is this so? so how can i solve it?

Hey hsadan,
Look into the movie clip symbol and find out where the movie actually plays. If there are any blank frames before the actual movie starts, you will not see the actual movie until the blank frames have been played through. Another possibilty, the movie clip contains so much data that takes your computer a short delay to process all that information.

The latter holds true when you are viewing the animation on your computer. If you are watching the movie on the internet, it could take some time to actually download the movie clip and play it. That is where a good preloader would come in. With a preloader, all the data would be loaded and, thus, preventing a delay. Hope this helped.

Kirupa =)

hey thx for replying…however i don’t think u understood my question…either that or my problem is a funny one :x

-i don’t have any blank frames…
-and it’s a movie clip symbol that contains some rectangles moving around for 70 frames…how big can that be?:-\

Do you have a link to the animation? I might need to see if it freezes on my end of the computer as well.

Kirupa :nerd:

um…think it might help if i provide the fla file…


it doesn’t freeze, the clip jsut doesn’t play -_-

Hey hsadan,
This is strange. It played perfectly on my comp. The mask effect worked well, and the rectangles moving worked without any delay or pause. The movie is only 1.26 KB in size, so load time is not the cause. I don’t know why you are experiencing problems. What processor and how much RAM do you have free when running that animation?

Kirupa :frowning:

i put a preloader in it, it showed everything has been loaded…but it still doesn’t play :frowning:

thx for trying, looks like u won’t be able to help me right now…(i used flash 5, btw)

Hey hsadan,
Sorry about that, I used Flash MX. You are right, the movie does not play the rectangles. Select the rectangles and in the Instance Panel, select Graphic. The rectangles play perfectly now. I don’t quite know why the rectangles wouldn’t work when they were stored as a movie clip.

Kirupa :rambo:

hey thx! we’re getting warmer…it turns out only the 3rd layer of the movie clip (the bottom layer, in this case) was played. the rest didn’t seem to be there :frowning:

btw, i tried unmasking it, and the movie played perfectly (without the mask effect ofcourse); but once i did the masking it didn’t work anymore…:-\