MX return to main timeline

Im in a movie clip, on the 1st frame of my main timeline.

Once my movieclip has reached a point/finished, I would like return to the main timeline.


what? what are you talking about! All objects are displayed no matter what timeline they are on!

Ok, This is my setup.

On 1st frame of main timeline, I go into a movieclip (1). Then into a another movieclip (2), which is inside mc1. Now, I have a movieclip (3) on the MAIN TIMELINE… How do I target that?

I’ve tried _root.movieclip3.gotoAndPlay, but because Im already in a movielcip, is that wahy its not working?

I want to get to the ABOSLUTE root/timeline of my movie…

_root.movieclip3.gotoAndPlay(frame no.) Should work, unless u had mistaken with the instance names.

Try instead of _root.movieclip3.gotoAndPlay;

Tried that as well Sorcerer:*(

Thats wot I thut - ITS NOT WRKING!!!

Heres my flash so far:


| |
| |
MC 1 MC3
MC2 HERE is where I need the code to target MC3



although it’s exactly the same as _root.MC3.gotoAndPlay(10);, but try it anyways.; HAS TO WORK!
check the instance names and stuff just to make sure!

Both should work syko. :o Try attaching the Fla File.

this is strange!:crazy:




That wrked - thanks every1, esp h88 SUPER MODERATOR!

Cld hav possibly been bcoz the mc I was trying to target was previously a graphic symbol, which I then changed… sumtimes u hav to delte the symbol and make it agian for it to register, rite???

You can’t target a graphic symbol :q:

Yes I know u can only target MCs (whice are symbols neway!!)

Wot I meant was - I had originally created a graphic symbol, which I then wanted to target, so changed its behaviour to a Moveiclip.

And I dn think Flash recognizes wen u do this… maybe a bug, as Ive kum across it in the past. I fI want to change one symbol to anutha IE graphic-movieclip, it only works if I delete the symobl and use a new one - just changing the behaviour duznt seem to wrk!!!:q:

Hmm, I’ll test that later.