Using Flash 8;
Hey all,
I’m wondering where to correctly place “removeMovieClip/UnloadMovieClip”? My entire page lives in the first frame, so I can’t go to the last frame and call it.
First, I guess, do I need to use those calls? I have a photo gallery page, so when I load each .jpg into a container MC, do I then need to remove that same MC? Right now, I don’t do that and things seem fine (except for nesting, but that’s another issue).
If so, do I call “removeMC” in the “createMovieClip” function itself, at the end of the function? Do I call it from somewhere else?
Also, I have read I need to swapDepths. //my_mc.swapDepths(666); // specify any available depth; before I call //my_mc.removeMovieClip();
Here is my container code, below, where I load the .swf slideshow movies. Should I use “unloadMovie” here in each onRelease call to first load, the unload each movie?
///////
var containerMC:MovieClip = _root.createEmptyMovieClip(“photoMC”, _root.getNextHighestDepth());
photoMC._x = 120;
photoMC._y = 150;
_root.subCatMC1.onRelease = function(){
// load mc1
photoMC.loadMovie(“swf1.swf”);
} //end on(Release)
_root.subCatMC2.onRelease = function(){
// load mc2
photoMC.loadMovie(“swf2.swf”);
} //end on(Release)
_root.subCatMC3.onRelease = function(){
photoMC.loadMovie(“swf3.swf”);
} //end on(Release)
_root.subCatMC4.onRelease = function(){
photoMC.loadMovie(“swf4.swf”);
} //end on(Release)
my_mc.swapDepths(666); // specify any available depth
my_mc.removeMovieClip();
////////////////////////////
Thanks for your help!!