E-mail server setup

Hello, I’m trying to settup James on my server and seem to be having some troubles.

  1. To create users, it says I have to telnet the host and port. How do I ‘telnet’ something?

  2. How do I know when it’s running, unlike Apache it closes without waiting for you to read everything it did. It scrolled through tons of stuff and closed real fast, is that god?

  3. Can somebody explain to me a, and mx records. My domain register let’s me fill these in, but I have no idea what to put there, should I put my ip address?

  4. Since I don’t have a static-ip, I use no-ip.com. Can I just replace my ip address with my account there which seems to act the same way?

Thank you so much, if you can answer any, or all, or these questions I’ll be very grateful.


1:telnet ip port :slight_smile:

telnet 25

2:try sending a email :slight_smile:

oh I figured out telnet thanks, but I don’t think it’s running, and I don’t know why, it closes automatically on run… and the telnet failed to, and what about 3 and 4?

3:Lol, i hate mx, would like to do things with ti but… just cant seem to get it hehe.
4:quote:which seems to act the same way

If it doesnt return any errors, and it works why bother

so I don’t have to have a and mx records? isn’t that the only way to have my domain forward all the email to my server? and tehn let me send mail as if it was from my domain?

Once started you’ll see a message saying Avalon is running. This means that Avalon has loaded JAMES and every other needed Block (see /logs/avalon.log) and is now waiting for a socket request. Since at the beginning James is empty, it will not have any local users registered. To register a local user open a telnet session with localhost on port 4555, log in as root (“root[enter] <password-you-set-in-conf.xml>[enter]”) and type “help” for a list of available commands in the “JAMES remote administrator tool”. It is really a basic set but should allow you to test installation.

Did you see that message ?

if not back to [font=arial,helvetica,sanserif][color=Black]Step 2: Configuration. [/color][/font]

whenever I want to start it should I be running the run batch file? 'cause that’s the thing that keep automatically closing

when I try to telnet my computer it gives this error:

Connecting To localhost…Could not open connection to the host, on port 23: Connect failed

which would make it seem that james isn’t running, can I talk to you on aim?

A JVM must be present and its location specified in the JAVA_HOME environment variable. Set this on windows at the command prompt with something similar to “set JAVA_HOME=\jdk1.3\bin”


To register a local user open a telnet session with localhost on port 4555, log in as root (“root[enter] <password-you-set-in-conf.xml>[enter]”)

urmmmm port 4555 says my index.html of james/docs/index.html

I put in teh set java home code and it didn’t say anything, is this good?..

and I couldn’t figure out how to login, I feel so stupid… but login isn’t a command prompt line, and when I put in the stuff with quotes and put in my password it said the file didn’t exist

Login @ command line.

look do this. according to my index.

telnet localhost 4555
> root [hit enter]
> password-you-set-in-conf.xml [hit enter]


type “help” for a list of available commands in the “JAMES remote administrator tool”. It is really a basic set but should allow you to test installation.

how, when I type telnet localhost 4555 I can’t do a return 'cause it gives me an error and then won’t let me login

#this might help however you shouldnt really need this
type ipconfig /all
copy ip
telnet ip 45555

And whats the error ?

if you cannot telnet into it: Back to Step 2: configuration (install.html)

and did you read of the index.html


Connecting To…Could not open connection to the host, on port 45555: Connect failed

I tried 4555 and 45555, neither worked, or did you want me to use my external ip? I used my private but I doubt it makes a difference

I’ll go over those pages again… then come back :stuck_out_tongue:

do I need ant seperately, or is it already inside of james when I downloaded it?

If you have downloaded a binary distribution, you do not need to build James. Proceed directory to Step 1.
To compile James from sources you need Ant. This is a Java-tailored, XML-configured, extensible build or make system. We are currently using Ant 1.4, which is included in the source distribution.

If you did download src than you should download bin instead

I downloaded binary, ok, I’ll continue looking, thanks

ok, so I got pretty far along, but now I’m getting a new error:

Using PHOENIX_HOME: C:\james-2.2.0
Using PHOENIX_TMPDIR: C:\james-2.2.0 emp
Using JAVA_HOME: \jdk1.3\bin
The system cannot find the path specified.

are these variables correct? I know that’s where the file is, a minute ago I got it to get the file correctly but then I closed it, is there a way to get command prompt history?

where is the java installed, did you even install it ?