Having Trouble Getting Preloader To Work - Help!

Just like the header says, I’m new to Flash MX and having great difficulty getting the preloader to work. I have followed every preloader tutorial here and none of them seem to work. Is there anyone here who can help me out.

it would be a waste of space to make a new thread so i posted here

i need a little help

can i combine a spinning animation made in swift3d and a percentage preloader… if so… how?

What problem are you having with the preloader? It’s not displaying correctly, or not working at all…?

Honestly Guys,

The whole **** thing is NOT working at all… I am truly frustrated with this stuff. I have followed the tutorials and the **** things don’t work. If you can help me I would appreciate it.

You’re gonna have to explain exactly what is going wrong. I haven’t had any problems with the tutorials, myself. Just make sure you are adding the preloaded to the first frame, of your first scene.

Or, wherever else you feel the need to preload.

Hey Guys,

Here I am again. Let me ask this question of you first. I have followed the directions to the Kirupa tutorials for the preloader. When I have it installed in my movie I should be able to preview the movie and see the preloader do it’s thing, right or wrong?

Well, I do follow the tutorials exactly. I put the preloader and in the first frame, on it’s own layer. Then I view the movie and I never see the preloader at all. The few times that I have seen it, it does nothing. It just sits on the face of my movie and stays there while my movie plays…

Can anyone give me a hint as to my problem? Not sure if it needs more explaining, but if you need more just write me. Hell I’ll even send you the file so you can look at it yourself.



No offense, but if you’d followed the tutorial exactly, it’d work. :slight_smile:

First, when you hit ctrl+enter to view your movie from flash (or manually begin play) do you get any actionscript errors?

Also, I never got to see my preloader for my first movie to work until I used the file:preview:html function. It was -already- loaded all the other times. :stuck_out_tongue:

Hey there,

Just wanted to let you know that no offense taken. I have followed the tutorials and I get no action scripting errors. I try to publish preview in HTML and I never see the preloader do it’s thing? Can’t seem to figure it out. I will try it one more time. If I have any problems I will let you know and see what you can do for me. Thanks again.

Just to boost up the file size and test the preloader I add a full size .mp3 to the mix, and when I find out it works I just take out the song.

Viewing the file on your computer will not show a preloader. You will need to upload it to a server and check. If the file is being read off of your computer, the load time is so fast it needs no preloader.

I too have done the tutorials on this site and found that they work.

Ah, LostInBeta, the God of outdoing me. :stuck_out_tongue: I was going to say that, if you movie is 10k, and you’re running cable, you’d never see the preloader in the first place.

I learned that one the hard way :-\

HAHA :stuck_out_tongue:

But yeah, I usually add a full song in .mp3 format instead of a loop then upload it to test it out. This process works great for me :beam:

Hey guys,

thanks for all the help. I now have a new problem… I see the preloader, but it won’t go away. Is the Preloader layer supposed to be the very first layer with the preloader in the first frame? Or is it supposed to be the very last layer with the preloader in the first frame? If you’d like to see the file you can go to


Let me know what you think.


Hmm, interesting. I am running on a cable modem and all I got was a blank black screen. I didn’t even see the preloader.

It doesn’t matter what layer it is in, as long as it is in the first frame(s) of your movie.

Maybe it’s just me, but I don’t see a preloader at all. In fact, on my 56k, it’s still a big black box. Try putting the preloader in the very first frame, of the very first scene. It’s either in the wrong place, or not working. :-\

Edit: Quit typing faster then me! :stuck_out_tongue:

HAHA, sorry, I do that to a lot of people. I seem to have a nack for posting at the same exact time as other people.

I guess it is an acquired skill :evil:

Okay, it works now. I got a navigation looking thing up, but the proloading screen (I suppose) that said ‘Loading Complete’ went away as soon as I selected an option from the other 7 you have (None of which have content.)

When you click ‘Home’ it does show the preloader bar again, I think you accidently put it there (Meaning, first frame that is not empty, beside the preloader.) Try make a clean first frame, and putting only the preloader in it.

Typetypetypefast :stuck_out_tongue:

All I am getting now is a big white screen. It used to be black, but now it is white. Still no content showing…hmmmm.


check it out now. Let me know what you see.

Hmm, I still get the same thing. I even cleared out all my temp internet files and cookies and all that junk. Still just get a white screen. I keep it open in hopes that waiting will make it work, but no luck.

I am sure Reggit can help with your problem. My computer does this sometimes…grrrr. By the time it will work again you will probably have the problem solved though.

Horrah. Clear temp files Big black screen, no loading. Did you reupload your .swf file to your server? :stuck_out_tongue: If so, check your .fla again, make absolutly sure you’re putting the preloader on your first frame, first scene, of your entire movie.

Additional: I found out that it’s also not loading your whole movie. After I clicked one of the buttons, 5 or so minutes later, I got something that said ‘Coming Soon’ fairly large, faded in. So the buttons do work, just aren’t being preloaded.