Making The Flash Menu Go Awaaay!

I published a flash animation for my site. When I go to the page it loads correctly, but when I right click on the animation is displays a menu. How do I make that menu inactive? So that when it is clicked on, nothing comes up.

Is it something that I have to do when I publish???

I’m Clueless!!!

Yes it is. Instead of doing a Ctrl+Enter to publish, go into the Publish Settings on the File menu and check the appropriate boxes. I think it’s something like ‘Protect From Import’? Can’t rememeber exactly. But that’s where it all is.

just insert the following code into your flash html tag:

[COLOR=royalblue]param name=“menu” value=“false”[/COLOR]

Thx, I was wondering too, gotta wright down that code somewhere.

Yet another post Andy, but I’ll suppress that one. Just to say that I’m putting this in the Best of Kirupa waiting for someone to put this in the tricks, even though it’s not AS, it’s very useful.

pom :cowboy:

when you publish the file, in the HTML menu just remove the tick from ‘Display Menu’ option.This will definately solve your problem:smirk:

that didnt solve it for me

Them menu never completely goes away. You can narrow it down to Settings and About Flash Player.

Getting rid of the menu just gets rid of zooming, rewind, fast forwading, etc.

my advice:

put it into any frame…
[AS]getURL(“FSCommand:showmenu”, “false”);
getURL(“FSCommand:trapallkeys”, “true”);[/AS]


you could also use this… in ur .swf (FMX)… then u dont need to add code to html …

[AS]Stage.showMenu = false;[/AS]

Sorry, I’m confused. Which is the best way to get rid of the menu?

Too many options :slight_smile:


Stage.showMenu = false;

in the first frames actions.

Though one way isn’t better than the other, they both do the same thing. Not sure if any of them is more ‘efficient’ than the other. Pick whichever one suits you best… hehe. Either way, there is no way to completely remove the menu (although in MX2k4 you can add custom options, they still don’t let you remove that menu)

Neither *[color=Blue]Stage.showMenu = false;[/color] nor [color=royalblue]<param name=“menu” value=“false” /> [color=Black]work to remove the Flash menu while you’re using the Firefox browser.

Is there another way?[/color]

getURL(“FSCommand:showmenu”, “false”);
getURL(“FSCommand:trapallkeys”, "true)

FScommand is generally for projector files (exe) and isnt such a good idea in this case.

Just use the tried and tested
Stage.showMenu = false;


Jaded: Did you update your plug-in for the firefox browser? I’ve tested these methods in my Firefox and do not experience any issues.