[MX] - _x/y of empty mC - should be simple!

Okay this is really starting to drive me nuts! What is wrong with this code?

on (release) {
_root.createEmptyMovieClip(“container2”, 1);
loadMovieNum(“calendar2.swf”, 1);
_root.container2._x = 205.8
_root.container2._y = 34.3;
trace (_root.container2._x)

It puts it at (0,0) of the _root! I tried “this”, I tried “_parent”, I tried nothing at all in front of container2. I even changed the x and y to something ridiculous. The trace returns the correct value but the clip ain’t budging. Why?! :hair:

You are creating a movie clip but loading the movie into level? You should be loading it into the movie clip you created.

yeah, well . . .uh . . . I knew that! I was just testing youse guys . . . yeah! That’s it!



come on loonie, i’ve taught you better than that! jk, hehe :stuck_out_tongue:

I know! And that is what is so dang frustrating! :upset: You’d think I’d get this stuff by now but I guess we all have our up late/too much rum and eggnog nights, heh heh

Pretty soon when I have a dumb question I’m just going to have to reregister with a different name - wipe my slate clean! Think I’ll call myself “dumb*ss” . . .