Problem with target in flash MX

Hey gang,
I have yet been able to really get used to this MX but have been dealing with it. I am doing things and not sure why, but as long as it works I just keep tuggin along. Here is one good example of a problem that has came up again that I never had much problems in flash 5 with, its the target command, Now that its deprecated. I am trying to use other methods.
Here is the problem, I an on main timeline, when timeline reaches a certain frame, it starts a Movie (MC1). When that movie gets done playing at the end, I have this on the last frame.

    Which starts another movie (MC2).  Now when MC2 gets all the way to the last frame, I want it to go back to MC1  But start on the 47th frame in that time line, What is the proper code to do this? I tried using something like this.

But it didn’t work. This was also from a button command by the way. on release… Before was so simple when I could use targets, but don’t have a clue here. Can anyone help please?
Thanks in advance.


_root._level0.gotoAndPlay is the same as
_root._root.gotoAndPlay if you are already in the main time line.

Just use _root.gotoAndPlay.


to target any mc it’s easier to always use the full target path. So whenever you want to refer to mc1 just use


and if you want to target mc2 just use

_root.mc1.gotoAndPlay and if mc2 is inside mc1 use


Do a search on this here because this question gets asked nearly every other day.

If you still have probs, post again.

First of all, I appreciate your kindness and explainations, I didn’t know that level0 and root was the same thing, that was one thing I was always confused on,and that helps out. To this day, I still can’t tell what levels are… anyway, nevermind all of that, I have tried the code, which I had already tried before the post by doing my usual painstakin trial and errors, it didn’t work then and still doesn’t. I don’t know why, except for the fact that I suck at programing.
I am using a button which I have pop up on the last frame on the main timeline which I am using to execute this command.

     on (release) {

Now why won’t it work?

          Thanks again for your help

If you post your fla I can take a look at it.

Levels just mean the level you load the movie into.

When your first movie loads, it’s called level0. If you load a movie into level1, it will load a movie on top of level0 and won’t replace it. If you load another movie into level2 it will load on top of level1. Do you understand?

If you load a movie into a level that already has a movie loaded into it, the previous movie will be replaced.

_root refers to the main timeline.

Also remember, that _root and _level0 mean the same thing if you have only the main movie loaded up, but if you load another movie into level1, if you say _root in any action in any object in level1, _root refers to the main time line in that level (level1) not level0.

Sounds complicated but it’s not.

So in other words, If I am on the main timeline, that is level0 or _root, and if there is a movie clip on that main timeline that it starts playing on, that is level1?

Ok, I am going to upload my .fla file, I just hope you can understand it, I am not the neatest programmer, but am working on it. I will post it up as soon as I upload it. Thanks for the help, This has been one of them projects that I am doing for a client that has dragged on, for one thing, they keep wanting me to change different things, which I am used to that anyway…LOL…

GRRRRRRRRRRRRRRRRRRRRRR, You have to be an imbosolt to sit here and let this get the best of ya. This sux :frowning: I give up people, I can’t get it to work, I am following flex’s path and it just won’t work. :frowning: I am beyond pissed, anyone else pissed tonight? these things really do piss me off.

Did you get my private message?

Actually i had a hard time this afternoon with my 3rd entry in the contest, My variables refused to coop, and i was on the verge of throwing my computer out the window… but then, god appeared, an told me to remove a useless keyframe on my bugging layer… and that was the end of my sorrows…=)

What I told you may or may not work. I can’t be sure till I’ve seen your fla.


I don’t think God appeared - I think it’s too much coke (and probably not the cola kind!)

HA HA HA, to much… just to much, … I went to the store and took a breather, I am back, and see that out of the whole internet, there was one other person that had a rough time, now somehow I just don’t agree with them statistics :wink: There had to of been more computer bashing attempts… Anyways Flex, I didn’t get the message, Is there something I click on around here?? Hmmmm, Coke? Gave that up when I woke up one morning and realized I had no steroe, and had no big screen tv and was sleeping on the tile floor… What memories… Ooops, back to topic here, I will send the FLA To you right now, the site is, you will notice the replay button is not working, I have a little more work to do with this client, I am making a static page as well so the dial up users can click on that. And of course us flash lovers with broadband will click on the link that I am having trouble with. :wink:
Flex, I will send fla now.

ahhhh, that coma screwed up the link

For me, I get an email when I get a Private Message, and if I’m on line I get a prompt telling me I have one.

Click on User cp at the top of the screen next to the Register button, then it should tell you if you have any pms. Or just click on Private Messages.

Where did you send the fla.?

I have the link to the site, but I need the fla. My email address is olives at Replace at with @. Or post a link to the fla.

I finally figured out that PM’s, I responded… I also uploaded that fla to the same link that you have, if you have any problems let me know and I will send it to your email. Thanks

Ok - got the zip and am going to go through it - send me another pm or email me with the problem in as much detail - I understand the first post you did - but a more detailed explanation would be helpful.

ok, I will, I will explain and send it to ya, on its way, give me a couple secs,

Check your private messages.

I’ve just noticed another replay button pops up - with another invisible button that leads to a mail to link. You need to get rid of that - I think I’ll have to have another look at it - I think I was too quick…

Like I said, you rock, that is what I wanted…I am sending you email now as the PM was to many words, it wouldn’t send. That other replay was something I left on when I was trying it in a different place when it wasn’t working right for me. So I was trying it in different MC’s. Luckily you took the right one that I originaly put in and where I wanted it to be. Thanks a bunch for the help. I wanted to know what syntax you used for that, I explained everything in email, I won’t repeat it all here. Thanks a bunch.