Weird Trouble with beautiful caps es swash capitals ttf

ttf Font Beautiful Caps ES Swash Capitals.ttf was employed last year to design wine bottle labels and the web site of my customer .
I ´ve just started to design a new lable and had a surprise:

1- As I type the text with beautiful caps in Adobe Photoshop , Macromedia Fireworks (eventually I tried the word processor) nothing is visualized …
I´ve got a blank (despite a black collor is selected - tried other collors as well )
No matter the quantity of points chosen !

2- I opened the Macromedia Flash files belong to the site and realized that
what it has been typed with this font in past still remains visible;
However if I try to type a new text with Beautiful caps the result is blank (It is possible to copy & paste) ;

3- I double clicked the .ttf file to find out that font design appears only in the headline ;
Unlike all others fonts I´ve seen up to now , the font design for 12 , 24 , 36, 48 , 60 points are not shown - only characters like [] [] are shown in lieu of ; just in case you want to take a look at it ;

I´ve downloaded from two other sources over the internet , deleted the existing one on my system and reinstalled, tried both for no avail ;

Can someone tell me what is going on and the possible solution ??



umm the only thing i can think of is to type the new text in flash (even though you can’t see anything appearing) and then break the text into paths…

once i had a fancy font (ardenwood) and when i would type it’d always be cut off and weird, but then once i converted it to paths it showed up ok.