Even my host can't help me (uploading .swf)

I am still having trouble uploading some of my .swf files to my host server. Some show up, some don’t. It is essential I solve this, because one of those .swfs is a navigation bar to my site. however if I upload the same files to my free angelfire account they work fine. here is what tech support told me:

.sfw files are set correctly to run on the server and on your site. You will have to check the way you are uploading the .swf file to our servers. I have checked 5 sites on the same server running .swf files and I can view them by linking to the .swf file. I can not view your .swf file by linking to the file. Here is a example site http://b2bsolution.us/intro.swf you will have to check the settings with http://www.afro-ninja.com/Page_Home/afromenu.swf Thank you

Check what settings? Is there a setting in the flash publish menu that says “publish correctly for readyhosting.com?”


help appreciated :frowning:

So with the afro-ninja.com thing, are you trying to load the movie, from b2bsolutions? - I’m confused. 'Cause if that’s the case, it could be anything. Maybe it’s your CHMOD permissions or maybe b2b is protecting the movie from being loaded. And yes, it can be done, Flashkit.com teaches how. :slight_smile:

are you abso-sure that you’re uploading to the correct directory within your site? … you could be buggering up the path

…can you see the files in the dir but they don’t play…or…?

i think bbsolution.us is another site on the same server as afro’s,
and he was pointing out that it was working fine.

linking to the file directly creates behavior in the browser like it’s
loaded an swf, however nothing shows as you say. Is this the
only swf that doesn’t load? How about a different example to
see, then at least you can rule out it being your server, and it’s
your movie instead.

check in your ftp that you’re using binary, not ascii, upload!

good call eyez…didn’t think of that :slight_smile:

and check that your filesizes are the same on your HD and on your site, sometimes servers just don’t seem to want to upload the whole files…

All right, here’s the update:

My ftp program was set to auto decide whether to upload in binary or ascii. I set it to binary only, and it still didn’t work.

The html files and their respective .swf’s are in the same directory, in a folder I created on my server

The files on the server and on my computer are the exact same size.

So far, this one file is the only one that uploads incorrectly. I’ve uploaded other things that work fine.

However, it seems that a movie will not even show up till completely loaded. If the movie has a preloader it wont even show it until the movie is all loaded :frowning: I haven’t extensively tested this though…

Here is exactly what happened when I tried an experiment (I posted this on an earlier thread but it’s kind of important)

I made a new file to the same dimensions as my nav menu. I pasted the graphics of my nav menu in it, uploaded it, it worked fine. Note that there is no AS. I added the buttons, again with no AS. I uploaded the file and nothing showed. Yet some of my other files have plain buttons

I’m ready to tear my face off >: |

I’m going to cry

ok, new “breakthrough”

the menu is composed of graphics, buttons, and a dynamic text box. The dynamic text box displays a name depending on what button you rollover

If I make the same menu but leave the buttons out, it works fine. If I make the same menu, but leave the dynamic text box out (with buttons still in) it works fine.

It makes no sense that my dynamic text box and buttons will not work together!

truly weird … why don’t you zip up and attatch the fla, swf and html here and maybe some little quirk’ll be spotted by someone …

ummm i dont see anything for either of those…

ya if u send me the file i can try uploading it

I’ll do that tomorrow, I gotta get to bed here soon. But still I don’t think it will help… I can upload the exact files the same way to my angelfire server and they show fine.