How to tween dynamic text?

I load dynamic text from a .txt file and it works fine. However, I cannot add any tween to the dynamic text field. I tried to use F8 to insert the text field as a symbl and add a tween for the symbol, however, the text cannot be loaded in after I made the change.

Can anyone help me look at this problem? The .fla and text file can be found:

Thanks a lot!

ok … you were right about the symbol. it does need to be changed. sometimes i have problems converting things to symbols from the stage especially variable elements or buttons so i usually just “insert > new symbol” from the start and save myself the hassle.

as far as your dynamic text not loading thats b/c in your first fram you have an onLoad command that tells flash to load the text into the textfield. you’ve told it the file name that you want it to load but when you specified where to load it to on the main frame that was fine. now its in a symbol that symbol has an instance on the main stage so you need to change the path in your code to reflect that move.

i.e. before your code was going to “textBox” now it needs to go to “symbolName.textBox”.

make sense?

once you have it in a symbol and functioning properly you should be able to apply tweens to the symbol.

Thanks a lot, shuga.

I did try to add the symbol name (textMC) in my flash file and I also insert a new symbol using Ctrl+F8, however, it still doesn’t work.

The new .fla file can be found:

i would love to look at it but unfortunately i’m at work so i cant see mx files b/c we havent gotten it in yet. all i have is flash 5 here … so if you want you can save it in flash 5 format file > saveAs or i’ll take a look at it when i get home tonight … b/c i have mx at home.

have a nice day:)

Again, thanks a lot, Shuga.

Here’s the flash 5 documents:

Enjoy the rest of the day! :slight_smile:


i tried everything i could think of but it doesnt work.

i dont understand why you’re loading a variable and specifying a frame in your code and i also dont understand why you give the load command both on the first frame of the movie and the first frame of the movie clip (symbol)

Anyways, thank you very much for your time!!! :slight_smile:

It doesn’t work, because of 2 reasons:

1 - loadVariablesNum is the wrong command. It’s loadVariables.
2 - textMC.loadVariables only works, if the INSTANCE of the movieclip has that name.

So change the command and name your movieclip-instance textMC and you’re done.


omgosh … duh

thx for thinking of that … apparently i had an “i am sofa king we todd did” moment


p.s. if you don’t get the sofa king referrence … read the sentence outloud several times until you laugh. then you will get it :slight_smile: