Module 10

I am having probs displaying the database entries after doing all the steps under the section “Retrieving Form Information from a Database.” Below is the output I get:\r-----------------------------------------------------------\rDatabase Results Error\rThe database connection named ‘database’ is undefined.\r\rThis problem can occur if:\r* the connection has been removed from the web\r* the file ‘global.asa’ is missing or contains errors\r* the root folder does not have Scripting permissions enabled\r* the web is not marked as an Application Root\r-----------------------------------------------------------\r\rI’m running the above at my webhosting site, and it’s running Windows NT. The only thing I can confirm is that the “global.asa” is not missing, but I have no way of telling if it contains errors. I have no probs entering or saving data into the database using the steps prior to the above section, just can’t retrieve it. Any ideas? -Lou-

Hey lou2002,\rThe problem is related to how your FrontPage Server was configured. Because you are able to save information to the database, I am assuming that the “connection” has not been removed from the Web.\r\rTry the following steps to possibly resolve your issue:\r1.) Right click on the ‘folder’ containing the form page.\r2.) That folder’s Properties dialog box will appear.\r3.) Check the box for ‘Allow scripts to be run’.\r\rThat should enable scripting for that folder, and, quite possibly, solve your problem. Also, ensure that your Form retrieval page is in the .HTM file extension unless you are specifically told to change to .ASP. \r\rSome of the database/form features require the page to be saved in HTM. If you were prompted to change the page to the .asp extension, don’t change it back to htm. It will only cause further problems.

Thanks Kirupa for the quick response. I tried using the three steps you mentioned, but when I right-click on the folder containing the results.asp file, the entry having the “Allow scripts or programs to be run” is GREYED out. Because of this, I can’t enable it. I tried looking at other things to see what might allow it to be enabled, but couldn’t find anything. In fact, all of my existing folders under the Web Name have the same problem. Am I doing something wrong?? -Lou-

Hey lou2002,\rDo you have full adminstration rights to your Windows NT server? I think there might be a setting in your User Parameters that restricts you to only modifying certain server properties. If you are not the adminstrator, you could ask the adminstrator to change the setting for you.\r\rAnother approach would involve you creating another FrontPage Web inside your current FrontPage Web. Create a sample database and a sample results file and see if your problem is solved. When you create a new FrontPage Web, FrontPage might give you some basic access to editing the Folder/File properties to files inside your new FrontPage Web. That might be worth giving a shot.

Thanks again for the response, but I actually figured out what I was doing wrong. It’s rather longwinded, but I’ll give you the short version. I’d setup my PC running Win '98 as a Personal WebServer which I installed when I briefly used FrontPage 98. The Web name I was using had a DOS type path (i.e. C<img src= ALT=":"> My Documents\My Webs\etc…). I found out that in order to have the “Allow scripts to be run” non-shaded in the Properties function, you have to have the path to your site begin with www.etc… versus C<img src= ALT=":"> etc…\r\rThat was it. Once I created another website, I was able to enable the Properties for the appropriate folder and retrieving the info from the database was a snap!\r\rThanks again for the help!!\r-Lou-

Your welcome. I’m glad you were able to have your issue resolved.

Kirupa -\r\rI too am suffering from this issue of not being able to get d-base results returned, however I’m a little confused on how to resolve it. The “allow scripts and programs to be run” box in the ‘Properties’ of the folder where my d-base is housed is also greyed out, but I’m unsure on how Lou resolved it. So, I created a web inside my web and set up another d-base to check my permissions, but the same problem occurs. The administrator of my NT server is also confused about this problem, so I was hoping that you could perhaps provide a more detailed explanation of the user parameters needed to resolve the conflict or perhaps an alternative solution. Any help you could provide would be much appreciated. Thank you!\r\rJames Lopez

Hello James,\rI do apologize for the delay in responding, I am looking into this issue. I will respond back shortly with (I hope) a solution to this problem; it has something to do with the method the FrontPage Extensions are configured.\r\rThanks,\rKirupa

Thanks Kirupa! I look forward to your response. :slight_smile:

Hello James,\rI tried various possibilities to re-create your problem, but I’m not experiencing the same problems. I’ll still keep looking though. In the mean time, what version of the server extensions are you using? I found this on the MS Support base, and it might help your adminstrator:…us;Q265161