Simple mc fade in MX

I cant understand why i cant do it. I have a movie clip in the first frame then add a keyframe in 5, go back to the first frame and in the properties inspector, i choose color, then alpha and set to 0,
then to frame five and set to 50%. Then I select all frames and create motion tween. I get that darn yellow exlamation point again and an error when I click it (in the properties inspector). The error says "Cannot motion tween on grouped objects, but can’t I motion tween on mc’s? I just want a simple fade on a mc over 5 frames and I can’t do it. Any help would be greatly appreciated.

Also, If any one has figured out my question from my post yesterday about how to load and unload an swf using a button. I would be so very happy:) I am just learning and the more I learn I will contribute back, I promise:)

Attachment to the later question is included in this post with explanation of my problem loading and unloading swf with button.

Thank you,

have you just tried right clicking one of the frames between the two keyframs and selecting Create Motion Tween??? I dunno, try it and see - although it seems like what you said should work.


If the message says the objects are grouped, ungroup them (CTRL +B at both keyframes). Failing that if you use the code:

[COLOR=blue]onClipEvent (load) {
_alpha = 0;

onClipEvent (enterFrame) {
Originally I thought of putting a limiter to stop when the alpha got to 100%, but then I thought that the alpha setting can not go higher than 100% so it would stop itself.

The limitation is that the fade in speed would be determined by the fps. Unless you made the mc at a different speed to the rest of the movie. Read this

now i remember, when creating a motion tween you can’t use the same object, must make is a new one. I think i got it right now, the tutorial i was using was confusing and it was for flash 5, I i kept messing up. THank you

I still keep getting an error when I create a motion tween. I tried these diff things. The motion tween still works when I run the movie, but the exclamation mark with an error when I click on it, is still there. Heres what I tried:

I tried ctrl+b to break apart

I tried using two diff objects

I still get this darn exclamation and an error, is this normal?

attached is a swf screen shot of the prob with explanation.

Thank you so much for your replies, i find it very helpful:)

I have been selecting both frames then creating the motion tween, when I do this it appears as to seperate tweens, but when I go to frame one, create motion tween, then to the last frame and create motion tween, it works fine:)

thank you,

i’m getting that same exact problem, but it still isn’t working even after i tried what worked for u toad