What is the difference between LoadMovie and LoadMovieNum

I’ve used both of these trying to solve my problem and nothing is working.

I am loading a movie into a movie. the movie being loaded into the other has controls on it that cause it to play forward and backwards. when it loads it’s not supposed to do anything until the user rolls over one of the buttons. it just plays … and it doesnt respond to any of the buttons.

when i use LoadMovie i have to change the _x and _y position of the mc, which is fine bu the movie plays and doesnt respond as described above

when i use LoadMovieNum the movie moves to a different _x and _y position but doesnt load the external file at all.

in both instances i’ve tried changing the level from 0 to 1 as suggested in the LoadMovie tutorial by kirupa on this site.

i don’t know how to fix this so if someone could help me i would greatly appreciate it


sniffle … i’m so hurt
no one will help me ;(

In my knowledge loadmovie(“url”,_target) is use to loadmovie into particular target of movie.

and loadmovienum(“url”,_level) is used to load movie on partivular level.(which is 0 to N num)

basic differece is _target and _level.

may be this will help u


that helps me understand the difference … but i guess thats not my problem b/c i still havent solved it … stupid movie clips

it works fine if i have the movie as a part of the main one and i don’t use the loadmovie … problem is i have over 300 of them i need to call on so it would be a really huge load time to put them all in the movie. sigh

i guess my queries are too advanced for even pom, inigo and lostinbeta
sniffle ;(

p.s. nice icon ranish :slight_smile:

Ranish answered your question :slight_smile:

According to macromedia…

Action; load a SWF or JPEG file into the Flash Player while the original movie is playing. The loadMovie action lets you display several movies at once and switch between movies without loading another HTML document. Without the loadMovie action, the Flash Player displays a single movie (SWF file) and then closes.

When you use the loadMovie action, you must specify either a level in the Flash Player or a target movie clip, into which the movie will load. If you specify a level, the action changes to loadMovieNum. If a movie is loaded into a target movie clip, you can use the target path of that movie clip to target the loaded movie.

A movie or image loaded into a target inherits the position, rotation, and scale properties of the targeted movie clip. The upper left corner of the loaded image or movie aligns with the registration point of the targeted movie clip. Alternatively, if the target is the _root Timeline, the upper left corner of the image or movie aligns with the upper left corner of the Stage.

Sorry I didn’t answer before… I didn’t know you posted this :frowning:

alright so now i understand the difference … thats awesome … but i still don’t have a working movie ;(

i guess i’ll have to post the source again tomorrow and maybe someone can help me.

Well if the movies you are loading involve pulling a clip out of the library (using attachMovie or something), they will not work.

I believe there is something called Shared Libraries that allow you to share the libraries of your loaded clips with your main movie so you can use the attachMovie method in a loaded movie.

I am not 100% on that though :frowning:

300 other movies is an incredibly high amount… :o

yea its for the same virtual tour i’ve been posting about for the past 3 months … i’m not using attachMovie at the moment but i’m open to any code that will make the **** thing work. i really just want to be done with it … but i have a few more things i need to make work. sigh that’ll teach me to open my big mouth at meetings about all the neat stuff flash can do.

Well what happens exactly when you try and load them in through loadMovie?

Do they just not show?

it loads … its loads at a funny _x and _y but thats easy enough to fix … the movie plays (it’s not supposed to play until a button in it is hit) and the buttons to tell it to do anything don’t respond

What are the actions on the buttons?

the actions on the buttons inside the loaded movie tell an mc inside that movie clip to respond to a script that tells it to play (loop) forward or backward

its a panoramic camera view that is just a movie of me turning the camera in a circle and then i have two buttons to simulate going left or right but actually it just loops the movie.

i wish i was at work right now so i could post the source :frowning:

I have no clue if this is true or not… never tested…

But possibly if you use _root or _parent your main movie reads it as that _root or _parent and not the one in your loaded movie. And hence the reason your buttons and such don’t work.

Just theory.

i do use _root … and that would make sense but if i don’t use _root how do i navigate it back up through the tree and then down another to the symbol i want to control … does “…/” work like it does in dos?

If that action is <U>inside</U> a movie clip on the main timeline of your loaded movie then you use _parent (this will bring you back 1 timeline and to the _root of your loaded moviie).

If your clip is <U>on</U> the main timeline, there is no need to use either.

sweet i’ll try that tomorrow at work … thanks a bunch :slight_smile:

crosses fingers hope this works

I hope it works too :slight_smile:

If not… I will still be here and maybe someone else will join in who can help.

hi guys,

as every1 will know soon enough i am nooooooooo expert at this


when i read the original post you seem to have a problem with the movie (inside the main movie) loading a movie that plays. this last movie you dont want to play as you are going to control it from your buttons

now, if i got that right (hahaha)

cant you just put a stop into a blank frame 1 of the movie you dont want to start on load. then control it by moving back and forward with the buttons and checking for frame 1 and “jumping”
it to aviod the stop during running of the movie?

it was just a thought…

if i am talking drivel then just laugh at me for being a complete moron and read the next post (which might actually help).



No… I think what you said makes completely sense… BUT…

THe problem isn’t with the movie itself. When tested, these movies works seperately… but when loaded they screw up.

So what we are trying to figure out is… why does that happen?

PS: Don’t be down on yourself… you probably know more than you give yourself credit for.

yeah i tried the stop thing just for kicks a few days ago but that doesnt help. the stop (even if the movie worked) would cause it to stop every time it came to that frame and the user would have to click the button again to go around the view another time. so that wouldn’t work.

i really appreciate the suggestion though

and like lostinbeta said … don’t be down on yourself that why the forum is here because no one is an expert in everything and we all have areas where we need help. :slight_smile: