Stupid buttons wont work (REDUX!)

Well, I was grateful for the help I received the first time, but I am back for more.

(.fla is added)

The content bar is working, but in order to animate the buttons like that I made them movie clips. When you highlight the button, it plays the movieclip right overtop of the button. I am not sure what went wrong here, but now, whenever I make an action for the button to actually do something, play an animation to show the news… it doesnt do anything!. Help appreciated, Comments are good too. Just incase some noobie flash guy comes along, and decides to download this, I removed alot of the site features, like bg animations, and music. Nothing with the content bar is tied to that.

Firstly, your button actions, the first one:

on (release) {

should be _root.content.gotoAndPlay. You need to target _root.content not just content. Content is outside of the timeline of the button.

Secondly, I didn’t find a frame label in contents called homebox. I did however find one called newsboxanim.

So your button action should be

on (release) {

Thirdly, you didn’t have a stop on the newsboxanim frame - the animation would just come and go. So I created a layer above you can use for stops and actions, and put a stop there, above the frame label.

I don’t know if that’s how it was supposed to work.

Here’s the fla.

Kudos to flex.

Senior Member

Registered: Sep 2002
Location: UK
Posts: 666

Is that code cursed??? :stuck_out_tongue:

666 doesn’t mean anything. Won’t bring you bad luck. Being one armed, hanging off a cliff, and having an itchy nose - now that’s bad luck.

Meh. Adding to the post, what should I do because when I click the news button it comes up as it should, but when I click it again, it goes back to the main site…

WAIT!, Dont correct me. I know how to do it.

Heh, another problem… Sorry for overasking but, I did what you said with the stop thing, but I decided to remove that so when you enter the site it would have it out already. Now I have a problem, It wont load the dynamic text…


There are so many threads here - and people can’t always answer your question straight away.

Explain your problem in more detail.

I don’t mean to be rude, but I think I am going to do like Eyez now. People who don’t explain their problem (“hey, my textbox doesn’t work. Any1 knows why?” How are we supposed to know?!?), and/or complain because they don’t get an answer… I’ll just ignore them. And you should do the same.


Ok, sorry for the confusion, but that was mainly directed to flex, who had helped me out before. If you look at the animation of homebox, at the end frame, it shows dynamic text box which is where the news is loaded to, but for some reason, the text isnt showing. I have the text file in the correct folder but I cant seem to figure it out. Thanks.

Well Ilyas is right. I’m not on call with my pager so if I don’t respond - maybe I’m busy?

And as for the not working - I have don’t have the text file or the changed fla so I, or anyone else wouldn’t know what you’re talking about.

On the contrary you do have it because you fixed it for me and if you dont have it, its attached again, but with the edited part. Regarding the text file, please just make one in note pad if you want to help. Copy and paste this if you please:


And just put it in the folder where the *.fla is.(not trying to insult your intelligence, just incase you arent familiar with it)

I only removed the first frame in the content movieclip that would stop the animation to show the home box. I removed it because I wanted that to play automatically when you entered the site. If you look at its animation in content, on the last frame the dynamic text is shown after the the animation. The code is as follows on that frame:

loadText = new loadVars();
loadText.onLoad = function() {
scroller.text = this.newstext;

I wasnt really sure where I should have put stop in the code on that frame, but I am sure it has nothing to do with it.

Regarding the whole entire situation about you guys thinking I think you are on a bell or somthing, I said hello to give this thread a boost to the top(which is sort of selfish but it works) because I wasnt sure if you would get to see it or not due to activity in the forum and people posting new threads and messages. I am most grateful for your help and time, I am learning alot from this forum.

I meant I don’t have the edited version. And I’m sure Ilyas was not just talking to you directly, because there are people who do think that people here are getting paid to help - hold on a minute - Ilyas - are you getting paid?

About the fla - I’ll look at it - I never complain about helping people - I always go out of my way - like most people here - Ilyas was just talking about people who say thinks like:

My buttons not working, help.


Well? Are you going to help?

Yes, I understand completely now. And i forgot somthing in my last post… The FLA!! sorry. :slight_smile:

Add a background to the text box. I don’t what your problems was in the script - might have been the text file

Yeah, sorry, I got a bit carried away. It’s just that recently, someone who didn’t get an answer within an hours started to say stupid things.

Anyway, everything seems to be working now.

pom :slight_smile:

It works now, much appreciated… Its cool harry potter man, no problems.

*Originally posted by theInvisibleman *
**Its cool harry potter man, no problems. **
Harry Potter Man… I like that :stuck_out_tongue: